Browse Source

Update dependency versions

master
Shadowfacts 2 years ago
parent
commit
db66a89399
Signed by: shadowfacts GPG Key ID: 94A5AB95422746E5
  1. 19
      build.gradle.kts

19
build.gradle.kts

@ -2,9 +2,9 @@ import com.github.jengelman.gradle.plugins.shadow.tasks.ShadowJar
import org.jetbrains.kotlin.gradle.tasks.KotlinCompile
plugins {
kotlin("jvm") version "1.3.40"
kotlin("jvm") version "1.3.50"
idea
id("fabric-loom") version "0.2.3-SNAPSHOT"
id("fabric-loom") version "0.2.5-SNAPSHOT"
id("com.github.johnrengelman.shadow") version "4.0.4"
}
@ -22,9 +22,9 @@ version = "0.1.0"
val minecraftVersion = "1.14.4"
val yarnMappings = "1.14.4+build.9"
val loaderVersion = "0.4.8+build.159"
val fabricVersion = "0.3.1+build.208"
val fabricKotlinVersion = "1.3.40+build.1"
val loaderVersion = "0.6.3+build.167"
val fabricVersion = "0.4.0+build.240-1.14"
val fabricKotlinVersion = "1.3.50+build.3"
val junitVersion = "5.4.0"
minecraft {
@ -34,6 +34,7 @@ repositories {
maven(url = "http://maven.fabricmc.net/") {
name = "Fabric"
}
maven(url = "https://kotlin.bintray.com/kotlinx")
jcenter()
mavenLocal()
}
@ -45,11 +46,11 @@ dependencies {
mappings(group = "net.fabricmc", name = "yarn", version = yarnMappings)
modCompile(group = "net.fabricmc", name = "fabric-loader", version = loaderVersion)
modCompile(group = "net.fabricmc.fabric-api", name = "fabric-api", version = fabricVersion)
modImplementation(group = "net.fabricmc", name = "fabric-loader", version = loaderVersion)
modImplementation(group = "net.fabricmc.fabric-api", name = "fabric-api", version = fabricVersion)
modCompile(group = "net.fabricmc", name = "fabric-language-kotlin", version = fabricKotlinVersion)
compileOnly(group = "net.fabricmc", name = "fabric-language-kotlin", version = fabricKotlinVersion)
modImplementation(group = "net.fabricmc", name = "fabric-language-kotlin", version = fabricKotlinVersion)
// compileOnly(group = "net.fabricmc", name = "fabric-language-kotlin", version = fabricKotlinVersion)
// compileOnly(group = "org.jetbrains.kotlin", name = "kotlin-stdlib-jdk8", version = "1.3.21")
// compileOnly(group = "org.jetbrains.kotlin", name = "kotlin-reflect", version = "1.3.21")

Loading…
Cancel
Save